Turbo Slider on UBUNTU - How enable audio!

Discussion related to Turbo Sliders and beta version feedback.

Moderator: Forum Moderators

Post Reply
DjDiabolik
Community User Level: 1
Community User Level: 1
Posts: 48
Joined: Mon Aug 14, 2006 6:42 pm

Turbo Slider on UBUNTU - How enable audio!

Post by DjDiabolik » Fri Apr 06, 2012 1:11 am

I have try to modify the sliders.ini:

Code: Select all

# Audio Settings

AudioOn 1
AudioDevice Default
CarEngineNumber 8
EffectChannelNumber 6
RemoteEngineVolume 0.500000
PositionEffect 0.100000
MenuVolume 0.500000
EffectsVolume 0.500000
MotorVolume 0.400000
SkidVolume 0.400000
MusicOn 1
MusicVolume 0.500000
But i start the games... sound it's mute.... can you help me ?

Del
Community User Level: 2
Community User Level: 2
Posts: 107
Joined: Thu Oct 27, 2011 1:27 pm

Post by Del » Fri Apr 06, 2012 7:27 am

First of all recomment the AudioDevice line. Try to run it from your TS directory in a terminal.
See if it says for example something like: "error: oss.c:179 cannot open /dev/dsp". If it says that you have to do "modprobe snd-pcm-oss" (may want to add that to /etc/rc.local or whatever it is that Ubuntu uses). If it doesn't say that try to run TS from your home directory (you'll have to copy some cars and tracks there probably). Post the two output.txts (from the TS directory and home) here (unless they're the same in which case one is enough).

DjDiabolik
Community User Level: 1
Community User Level: 1
Posts: 48
Joined: Mon Aug 14, 2006 6:42 pm

Post by DjDiabolik » Fri Apr 06, 2012 12:27 pm

Code: Select all

Game version: Turbo Sliders 2.0.0L (Linux) Built: Oct 12 2008 20:42:55
Default: OSS Software
SetPriorityClass not supported
  hw: 0 blit_hw: 0 blit_hw_CC: 0 blit_hw_A: 0
 blit_sw: %D, blit_sw_CC: 0, blit_sw_A: 0, video_mem: 0
Current video mode: 1152x864
Available modes:
  1280 x 1024 
  1280 x 960 
  1280 x 800 (wide)
  1152 x 864 
  1280 x 768 (wide)
  1280 x 720 (wide)
  1152 x 864 
  1024 x 768 
  800 x 600 
  720 x 480 
  640 x 480 
Video mode 800 x 600 (full:0 gl: 1 db: 1)
Screen properties:
  800 x 600  bpp: 32 Bpp: 4 pitch: 3200 size: 1875 kB (1920000)
  RGBA masks: ff0000,ff00,ff,0 shifts: 16,8,0,0 losses: 0,0,0,8
  colorkey: 0  alpha: 255
  SWSURFACE:  0  HWSURFACE: 0 ASYNCBLIT:  0 ANYFORMAT:   0 
  HWPALETTE:  0  DOUBLEBUF: 0 FULLSCREEN: 0 OPENGL:      1 
  OPENGLBLIT: 1  RESIZABLE: 0 HWACCEL:    0 SRCCOLORKEY: 0 
  RLEACCEL:   0  SRCALPHA:  0 PREALLOC:   0
GL Vendor: ATI Technologies Inc.
GL Renderer: ATI Radeon HD 4600 Series 
GL Version: 3.3.11251 Compatibility Profile Context
GL Max Texture Size: 8192
Arbitrary texture sizes supported
Initializing driver failed: ALDriver: Could not open device
channels > 16, retrying with other sound settings
Initializing driver failed: ALDriver: Could not open device
channels > 8, retrying with other sound settings
Initializing driver failed: ALDriver: Could not open device
Could not init audio, reverting to old settings
Localized string test: String test
String test 2 (personal best): New personal best 
SetPriorityClass not supported
Exiting.
g surfaceLocks: 0 - 0
alSamplesLoaded: 0 alSamplesFreed: 0
alGenBufs: 0 alDeleteBufs: 0
Look.... wtf ??
channel > 16 ?? or > 8 ?? i need 8 channel device to play this games ?

Del
Community User Level: 2
Community User Level: 2
Posts: 107
Joined: Thu Oct 27, 2011 1:27 pm

Post by Del » Fri Apr 06, 2012 1:16 pm

DjDiabolik wrote:channel > 16 ?? or > 8 ?? i need 8 channel device to play this games ?
No... When you run it in terminal (in the TS directory) does it say anything like "error: oss.c:179 cannot open /dev/dsp"? What does lsmod|grep snd_pcm_oss say? Open whatever general sound mixer/volume control unit (not alsamixer or anything) and make sure your OSS device has some volume.

It would be nice to be able to force TS to use PulseAudio somehow... I can do it by running it from inside my home directory (and my TS folder is ~/sliders/).

DjDiabolik
Community User Level: 1
Community User Level: 1
Posts: 48
Joined: Mon Aug 14, 2006 6:42 pm

Post by DjDiabolik » Mon Apr 09, 2012 8:07 pm

i have running with:
./sliders.linux

The games start.. no audio but no error on terminal....


now it's all slow.... the games stuttering all in opengl.

Othergames it's all ok :(

Del
Community User Level: 2
Community User Level: 2
Posts: 107
Joined: Thu Oct 27, 2011 1:27 pm

Post by Del » Mon Apr 09, 2012 9:30 pm

Try starting with ../(TS directory)/sliders.linux from your home or wherever (I highly recommend the folder that contains your TS directory as you may have to move cars and tracks there). Make sure one of your audio outputs says OSS (pic) and that it isn't muted.

DjDiabolik
Community User Level: 1
Community User Level: 1
Posts: 48
Joined: Mon Aug 14, 2006 6:42 pm

Post by DjDiabolik » Thu Apr 12, 2012 1:16 am

No... it's not mute.

But i'm back and reinstalled windows 7 because linux support amd it's very shit...

I can retry to reinstall ubuntu when it's out the 12.04 in italian....

zxcvbnnm
Posts: 4
Joined: Sun Mar 03, 2013 3:24 pm

Post by zxcvbnnm » Sun Mar 03, 2013 3:44 pm

hello im using ubuntu 12.04 and have problem with sound in TS. Im getting errors in terminal while running

Code: Select all

AL lib: oss.c:179: Could not open /dev/dsp: No such file or directory
im added "modprobe snd-pcm-oss" to the file /etc/rc.local but still getting this errors and no have audio can someone help me? what to do?

Post Reply